rxi/lite
A lightweight text editor written in Lua. Contribute to rxi/lite development by creating an account on GitHub.

Installation

git clone https://github.com/rxi/lite.git
cd lite
./build.sh

Si vous rencontrez des problèmes de compilation avec la lib SDL, vous pouvez installez le packet libsdl2-dev pour les résoudre :

fatal error: SDL2/SDL.h: Aucun fichier ou dossier de ce type
#include <SDL2/SDL.h>
sudo apt-get install libsdl2-dev

Exécution

./lite

Plugins

Plusieurs plugins sont disponibles sur la page https://github.com/rxi/lite-plugins

Pour ajouter un plugin, il suffit de l'ajouter au répertoire lite/data/plugins et de relancer le binaire ./lite :

Exemple du plugin language_sh qui ajoute la coloration syntaxique des fichiers shell

Thèmes

Des thèmes sombres et clairs sont proposés sur la page https://github.com/rxi/lite-colors

Pour ajouter un thème, il faut le copier dans le répertoire lite/data/user/colors, modifier le fichier lite/data/user/init.lua comme suit et relancer le binaire ./lite.

Pour activer le thème github par exemple :

-- light theme:
require "user.colors.github"
Rendu du thème github